Информайзер - руководство пользователя

Информайзер.

Руководство пользователя

Обновлено: 16 Октября 2002

Содержание

Введение

Лицензия
Инсталляция
Регистрация
Заказ программы

Задачи

Интерфейс
Меню
Панель управления
Виды задач
Горячие клавиши
Свойства
Типы задач
Первый запуск
Фоновая работа программы
Ввод задач

Контакты

Блокнот

Календарь

Ссылки

Работа шаг за шагом

Дополнительная информация

Введение

Цель данного документа - дать пользователю информацию о том как использовать Информайзер наиболее эффективным способом.

Так как Информайзер находится в постоянном развитии, то руководство не является полным описанием последней версии Информайзера и описывает только основополагающие принципы работы.

Снейкус: Привет. Меня зовут Снейкус. Я - начинающий пользователь программы Информайзер и иногда буду задавать свои вопросы от лица всех начинающих пользователей. Согласны? :O)
Таски: Хорошо, Снейкус. А я, Таски, как продвинутый пользователь Информайзера, постараюсь на них ответить.
Снейкус: Wow! Здорово!

Примечание: Руководство находится в стадии написания. На данный момент оно не являестя абсолютно полным. Возможны дополнения и уточнения.

[ к оглавлению ]

Лицензия

Лицензия на использование и распространение Информайзера
========================================================

ПЕРЕД НАЧАЛОМ УСТАНОВКИ И/ИЛИ ИСПОЛЬЗОВАНИЯ ЭТОГО ПРОГРАММНОГО ОБЕСПЕЧЕНИЯ ВНИМАТЕЛЬНО ПРОЧИТАЙТЕ НИЖЕСЛЕДУЮЩЕЕ ЛИЦЕНЗИОННОЕ СОГЛАШЕНИЕ

УСТАНОВКА ИЛИ ИСПОЛЬЗОВАНИЕ ЭТОГО ПРОГРАММНОГО ПРОДУКТА ОЗНАЧАЕТ, ЧТО ВЫ ПРИНИМАЕТЕ ЭТО ЛИЦЕНЗИОННОЕ СОГЛАШЕНИЕ. ЕСЛИ ВЫ НЕ ПРИНИМАЕТЕ ЭТО ЛИЦЕНЗИОННОЕ СОГЛАШЕНИЕ ИЛИ НЕ СОГЛАСНЫ С ПОЛОЖЕНИЯМИ ЭТОГО СОГЛАШЕНИЯ, ТО ВЫ НЕ МОЖЕТЕ ИНСТАЛЛИРОВАТЬ И ИСПОЛЬЗОВАТЬ ДАННОЕ ПРОГРАММНОЕ ОБЕСПЕЧЕНИЕ!

Информайзер распространяется по принципу "try-before-you-buy" ("попробуй, а затем купи"). Это означает:

1. Все авторские права Информайзер принадлежат только автору - Вадиму Щетинкину.

2. Каждый может использовать это программное обеспечение в течение тестового периода. По прошествии этого периода, если Вы хотите использовать Информайзер, то Вы должны зарегистрировать программу.

3. ИНФОРМАЙЗЕР ПОСТАВЛЯЕТСЯ ПО ПРИНЦИПУ "AS IS". НИКАКИХ ГАРАНТИЙ НЕ ПРИЛАГАЕТСЯ И НЕ ПРЕДУСМАТРИВАЕТСЯ. ВЫ ИСПОЛЬЗУЕТЕ ЭТО ПРОГРАММНОЕ ОБЕСПЕЧЕНИЕ НА СВОЙ РИСК. АВТОР НЕ БУДЕТ ОТВЕЧАТЬ НИ ЗА КАКИЕ ПОТЕРИ ИЛИ ИСКАЖЕНИЯ ДАННЫХ, ЛЮБУЮ УПУЩЕННУЮ ВЫГОДУ В ПРОЦЕССЕ ИСПОЛЬЗОВАНИЯ ИЛИ НЕПРАВИЛЬНОГО ИСПОЛЬЗОВАНИЯ ЭТОГО ПРОГРАММНОГО ОБЕСПЕЧЕНИЯ.

4. Вы не можете использовать, копировать, эмулировать, создавать новые версии, сдавать в наем или аренду, продавать, изменять, декомпилировать, дизассемблировать, изучать код программы другими способами, передавать зарегистрированную программу или любые из ее составляющих, иначе, чем определено настоящим лицензионным соглашением. Любое такое нелегальное использование означает автоматическое и немедленное прекращение действия настоящего соглашения и может преследоваться по закону.

Все права не предоставленные здесь явно сохраняются за автором - Вадимом Щетинкиным.

5. Установка и использование Информайзера означает, что вы понимаете положения настоящего лицензионного соглашения и согласны с ними.

6. Если почему-либо вы не согласны с этим лицензионным соглашением, Вам необходимо удалить файлы Информайзера с ваших устройств хранения информации и прекратить использование Информайзера.

[ к оглавлению ]

Инсталляция

Требования к аппаратному и программному обеспечению:

Процессор не ниже Intel Pentium 266

Память >= 64 Мб

Свободного места на диске >= 100 Мб

Операционная система MS Windows 95,98,Me,XP,NT,2000

Примечание: Чем больше памяти у Вас на компьютере - тем лучше. У программы в настоящее время есть скрытый дефект - имеется утечка памяти (после каждого сеанса работы теряется ~1 Мб памяти). Вывод - старайтесь минимизировать число запусков программы на компьютере! Следствием нехватки памяти могут быть сообщения типа "Out of resources" при запуске программы.

Процесс инсталляции.

Процесс инсталляции различается для впервые устанавливаемой версии Информайзера и повторно устанавливаемой: при повторной установке программа инсталляции обнаруживает базы данных пользователя и запрашивает затереть их или сохранить.

Совет: Следует сохранять имеющуюся у пользователя базу данных Задач (tasks.dbf), Контактов (contacts.dbf), Календаря (calendar.dbf и ru_calen.dbf) и Ссылок (bkmarks.dbf). Другие базы следует обновлять.

Каталог установки.

По умолчанию установка ведется в каталог "C:\Program Files\Informaizer 2".
Вы можете выбрать любой другой каталог по своему усмотрению.

После установки в данном каталоге создаются следующие подкаталоги:

Data | Содержит базы данных программы
Artwork | Содержит графику к программе
Fonts | Шрифты, используемые программой
Sounds | Звуки, воспроизводимые программой при наступлении различных событий
Help | Различная документация по программе
Lang | Поддержка различных языков (английский, русский, македонский)
Logs | Лог-файлы работы с программой (текстовые файлы - содержимое Блокнота, с именами, соответствующими датам работы)

Если Вы устанавливаете Информайзер в новый каталог (NewDir), а раньше работали с программой в другом каталоге (OldDir), то следует скопировать файлы баз данных Задач (tasks.dbf), Контактов (contacts.dbf), Календаря (calendar.dbf и ru_calen.dbf) и Ссылок (bkmarks.dbf) из OldDir в NewDir.

[ к оглавлению ]

Регистрация

Регистрация Вашей копии Информайзера

Если Вы хотите использовать Информайзер в своей работе, то Вы должны зарегистрировать программу.

Вы можете спросить: "Какой смысл заключается в регистрации?"

Во-первых, Вы поддерживаете разработчика материально, что дает разработчику хороший стимул заниматься дальнейшей разработкой и улучшением программы. От этого, в конечном итоге, выигрываете Вы, конечные пользователи программы.

Во-вторых, регистрация программы дает пользователю следующие преимущества:

Устранение ограничений в работе:
- у Вас перестанут генерироваться напоминания о необходимости регистрации, которые в незарегистрированной версии программы появляются каждый час.
Политика бесплатных обновлений
- за реристрацию программы Вы платите только 1 раз и на всю жизнь получаете право получения бесплатных обновлений к программе Информайзер.
Эксклюзивные авторские комментарии
- Вы получаете право получать эксклюзивные авторские комментарии относительно того как Вы можете использовать Информайзер в своем бизнесе.
Поддержка баз данных пользователей
- получаете поддержку Выших баз данных от авторов программы. Это значит, что если у Вас имеются какие-то проблемы с базами данных (повреждены, переполнены и т.п.), то создатели Информайзера пытаются разобраться в причинах произошедшего и восстановить Ваши данные.
Приоритетное право вносить изменения в будущие версии программы
- Вы приобретаете право вносить предложения по улучшению или кастомизации программы, которые будут учтены в первую очередь при разработке следующих версий Информайзера.
Участие в лотерее
- получаете право участия в лотерее по розыгрышу регистраций других shareware-программ.
Подписка на специальное информационную рассылку
- получаете первыми самые свежие новости об Информайзере.
Документация к программе
- первыми получаете документацию к Информайзеру в электронном виде с последними изменениями.

[ к оглавлению ]

Заказ программы

Регистрация Информайзера начинается с выписки счета на оплату программы.

Выписать счет можно обратившись по ссылке: http://www.swrub.com/order.html?productid=30-1 на сайте "Shareware за рубли".

Существуют следующие способы оплаты:

Счет на оплату для юридических лиц

Самый быстрый и доступный способ оплаты по безналичному расчету для юридических лиц и предпринимателей. Выписывайте счет, оплачивайте. После прихода средств на наш счет Вы получаете регистрационный код от автора программы. Позднее по почте Вы получаете акт-накладную и счет-фактуру на сделанную Вами покупку (не забывайте вернуть одну копию акта-накладной). Если желателен материальный носитель для отчетности, заказывайте CD. Он будет выслал по почте вместе с документами.

Банковский перевод для физических лиц

Вы можете оплатить оформленный счет заказ через любое отделение Сбербанка (сберкассу) или коммерческий банк. Для этого от Вас потребуется просто заполнить бланк перевода. Вы сможете также распечатать этот бланк со всеми параметрами Вашего заказа прямо из браузера и воспользоваться им при оплате. Оплата через банк обойдется Вам в 3% от стоимости заказа (в некоторых регионах местными уложениями эта сумма может быть увеличена - об этом Вам скажут в банке) - эти деньги с Вас возьмут при оформлении перевода.

В случае если Вы не оплатите отдельной квитанцией услуги Сбербанка, их стоимость будет автоматически вычтена из средств, отправленных Вами в оплату заказа. В свою очередь это приведет к тому, что из-за неполной оплаты заказ не будет выполнен, и Вам придется дополнительно оплачивать недостающую сумму в наш адрес.

Если Вы заполняете бланк банковского и почтового перевода вручную, обязательно указывайте в качестве получателя платежа ЗАО "Центр информационных технологий "АдаСофт".

Этот способ является одним из самых удобных и экономичных:
он обойдется дешевле, чем почтовый или телеграфный перевод - 3% от стоимости заказа вместо 8%;
проходит быстрее, чем почтовый , на это требуется 6-10 дней.

WebMoney

Вы можете осуществлять безналичные платежи через систему Webmoney Transfer.
Существует два способа:
1. Вывод средств из системы WebMoney. Для перевода в Вашем WebMoney Keeper необходимо щелкнуть правой кнопкой на кошельке, с которого Вы хотите произвести перевод, а затем выбрать из меню "Передать деньги в банк". Обязательно используйте только R кошелек и указывайте номер счета. Комиссия при данном способе оплаты будет составлять от 2.8% от стоимости заказа. Ограничение - суммы до 500 рублей. См. тарифы WebMoney.
 Облегченная страница ввода банковского платежа.
2. Перевод средств через систему WebMoney Transfer. Для этого необходимо после выбора соответствующего способа оплаты и оформления заказа, произвести перевод на кошелек SWRUB. Для перевода в Вашем WebMoney Keeper необходимо щелкнуть правой кнопкой на кошельке, с которого Вы хотите произвести перевод, а затем выбрать из меню "Передать деньги в кошелек WebMoney". В появившемся диалоговом окне необходимо указать сумму перевода и наш кошелек, а в примечании обязательно указать: оплата по счету "номер счета". Перевод необходимо делать без протекции сделки. После того, как Вы произведете перевод Ваш заказ будет принят к исполнению. Этим способом Вы можете оплачивать и с R и с Z кошельков.
Наш кошельки R212225714896 Z205580299327 Наш WM ID 399171293759.

PayCash

Мы также принимаем оплату через платежную систему PayCash. Для этого необходимо произвести вывод средств на банковский счет. Форма заказа вывода средств будет представлена при оформлении заказа. Комиссия при данном способе оплаты будет составлять от 3% от стоимости заказа.
Банкомат для перевода денег на произвольные банковские реквизиты.
Подробно о системе PayCash Вы можете почитать на сайте http://www.paycash.ru/.

Почтовый перевод, телеграфный перевод

От Вас потребуется в течение недели выслать на счет SWRUB перевод на сумму заказа, полученную Вами при оформлении, указав в бланке почтового или телеграфного перевода номер и дату заказа и уведомить нас о том, что перевод отправлен через форму, ссылку на которую Вы получите по электронной почте. Процедура регистрации начнется, как только оплата поступит на наш счет. Прохождение почтового перевода занимает от одной до шести недель, телеграфного - не более семи дней.

Однако мы не можем гарантировать, что почтовая служба не задержит перевод на неопределенный срок по независящим от нас причинам. Мы не несем ответственности за недостатки в организации работы предприятий Федеральной Почтовой Службы России. Если Вы хотите удостовериться, что Ваш перевод дойдет в разумные сроки, посылайте его с уведомлением.
При оформлении счета Вам будет сообщен его идентификационный номер и показан образец заполнения бланка перевода. Вы сможете также распечатать бланк со всеми параметрами Вашего заказа прямо из браузера и воспользоваться им при оплате. Стоимость почтового перевода составляет ориентировочно 8% стоимости заказа, для телеграфного перевода Ваши расходы увеличатся на те же 8% плюс 16 рублей 20 копеек за саму телеграмму. Более точные цифры Вы можете получить в своем отделении связи.

Из ряда стран СНГ (Украина) и из дальнего зарубежья почтовый перевод в Российскую Федерацию невозможен.

Наложный платеж

Выбирая доставку наложными платежом Вам, как правило, придется доплатить 8% от стоимости заказа + 30 рублей за услуги почты (уточните в местном отделении связи). Письмо будет содержать регистрационный код распечатанный на бумаге или записанный на дискете (в зависимости от формы и объема кода), или на CD при заказе CD с программами. Для подтверждения заказа с доставкой наложным платежом Вам необходимо будет выслать в наш адрес дополнительные данные (см. свою электронную почту после оформления заказа).
Внимание: не все программные продукты могут быть оплачены наложным платежом.
Смотрите также предупреждения для почтового и телеграфного переводов.
Юридическим лицам заказы наложенным платежом не отправляются!

Другой

Вы можете использовать иные способы оплаты счета, не представленные выше. Например, через систему интернет платежей (Рапида, КредитПилот или другую систему с поддержкой возможности перечисления средств на любой банковский счет), систему Домашний Банк или Western Union. Для этого предоставляются наши банковские реквизиты. Уточнить возможность использование другого способа платежа Вы можете написав по адресу payment@swrub.com

Финансовые документы
Вместе с заказом отправляются необходимые финансовые документы: акт-накладная и счет-фактура. Если по какой-то причине в Вашем заказе не оказалось необходимых документов, пожалуйста, обращайтесь по адресу order@swrub.com или по телефону (0942) 313180.

После оплаты счета Вы получите по электронной почте программу регистрации, которая зарегистрирует Вашу копию Информайзера.

[ к оглавлению ]

Интерфейс

Главное окно программы Информазер имеет следующие основные части:

Меню
- содержащее все команды для эффективных действий с задачами.
Панель инструментов
- набор кнопок для ускорения выполнения часто используемых команд.
Список задач
- основанный на компоненте DBGrid список задач с цветной разметкой, облегчаюшей восприятие задач и их состояний.
Протозадачи
- основанный на компоненте DBGrid список задач с предопределенным типом и свойствами.
Календарь на месяц
- элемент управления для быстрого изменения дат задач
Список извещений
- список уже полученных извещений (сверху - недавние оповещения, снизу - более ранние).

Внешний вид Информайзера при работе с Задачами показан на снимке с экрана.

Примечание: Снимки с экрана сделаны на Информайзере версии 2.5.0. Картинки версии, используемой Вами, могут немного отличаться.

[ к оглавлению ]

Виды задач

Все задачи, с которыми оперирует Информайзер условно могут быть поделены на следующие группы:
Задачи, созданные непоредственно пользователем
- включают все задачи, созданные пользователем в процессе работы: новые задачи, "клонированные" задачи, созданные из протозадач, и т.д.
Напоминания о событиях - напоминания, выставленные программой на основе анализа Календаря
- при первом запуске программы в течение одного (текущего) дня анализируется база данных Календаря на предмет наличия событий, по которым надо выставить напоминания.
Напоминания о датах из Контактов - напоминания, выставленные программой на основе анализа Контактов
- при первом запуске программы в течение одного (текущего) дня анализируется база данных Контактов на предмет наличия дат (дни рождения, памятные дни), по которым надо выставить напоминания.
Напоминания о регистрации
- генерируются программой каждый час (только в незарегистрированной версии Информайзера)
Метки дня
- генерируются при первом запуске программы в течение одного (текущего) дня или вводятся вручную самим пользователем на произвольную дату.
Предназначены для визуальной ориентации в списке задач по дням.
Метки времени
- генерируются при первом запуске программы в течение одного (текущего) дня или вводятся вручную самим пользователем на произвольную дату.
Предназначены для визуальной ориентации в списке задач по времени.

[ к оглавлению ]

Меню

Файл

Соединение - производит переоткрытие баз данных программы - необходим для обновления содержимого баз данных при доступе к базам данных других внешних программ
Печать - печать задач
Выход - выход из программы
Напечатать и выйти - выход из программы спредварительной печатью задач

Вид

Контакты - показывает/скрывает окно Контакты
Ссылки - показывает/скрывает окно Ссылки
Блокнот - показывает/скрывает окно Блокнот
Калькулятор - показывает встроенный Калькулятор
Календарь - показывает Календарь
Часы - показывает/скрывает Часы
Свойства задачи - показывает/скрывает окно Свойств задачи
Детальный Вид - устанавливает минимальный режим фильтрации задач
Упрощенный Вид - устанавливает максимальный режим фильтрации задач. При этом не отображаются: метки времени, шутки, напоминания, задачи с состоянием "Сделано", задачи с состоянием "Несделано".
Упорядочить по... - подменю выбора режима сортировки задач.
Дата, время - сортировка задач по дате и времени.
Состояние, Дата - сортировка задач по состоянию и дате.
Приоритет, Дата - сортировка задач по приоритету и дате.
Дата, Исполнитель - сортировка задач по дате и исполнителю.
Справочники - подменю выбора справочника для редактирования.
Состояния - справочник состояний.
Категории - справочник категорий.
Приоритеты - справочник приоритетов.
События - справочник событий.
Протозадачи - справочник протозадач.
Обновить - обновить окно отображения задач после редактирования справочников
Online - установка режима присутствия/отсутствия на рабочем месте
Показать последнее сообщение - показ последнего уведомления в окне бегущей строки

Правка

Вырезать - поместить в буфер обмена и удалить выбранные задачи
Копировать - копировать выбранные задачи в буфер обмена
Вставить - вставить задачи из буфера обмена
Удалить - удалить выбранные задачи
Удалить задачи за день - удалить все задачи за конкретный день
Удалить выполненные задачи за день - удалить все выполненные задачи за конкретный день
Удалить выполненные до... - удалить все выполненные задачи до выбранного дня
Удалить все выполненные задачи за день - удалить все выполненные задачи
Удалить напоминания за день - удалить все напоминания за день
Просроченные задачи - подменю
Перенести просроченные задачи с... - Перенести просроченные задачи с выбранного дня
Отметить все - Отметить все задачи
Разотметить все - Разотметить все задачи
Клонировать - создать задачи по образцу выбранных задач
Клонировать на... - создать задачи по образцу выбранных задач на определенный день

Задачи

Вставить - Создать новую задачу
Вставить на... - Создать новую задачу на определенную дату
Сохранить задачу - Сохранить задачу
Высший - Установить высший приоритет для выбранных задач
Высокий - Установить высокий приоритет для выбранных задач
Средний - Установить средний приоритет для выбранных задач
Низкий - Установить низкий приоритет для выбранных задач
Очистить приоритет - Очистить атрибут "приоритет" для выбранных задач
Менять приоритет - Выбрать приоритет ротацией для выбранных задач
В работе - Установить для выбранных задач состояние "В работе"
Заминка - Установить для выбранных задач состояние "Заминка"
Несделано - Установить для выбранных задач состояние "Несделано"
Сделано - Установить для выбранных задач состояние "Сделано"
Очистить состояние - Очистить атрибут "состояние" для выбранных задач
Менять состояние - Выбрать состояние ротацией для выбранных задач
Очистить тип - Очистить атрибут "тип" для выбранных задач
Перейти - подменю навигации в списке задач
К первой - переход к первой записи
К предыдущей - переход к предыдущей записи
К следущей - переход к следущей записи
К последней - переход к последней записи
Дата - подменю для установления атрибута "дата начала" задач
Установить дату... - Установить дату начала задач на определенный день
Перенести на сегодня - Перенести задачи на сегодня
Перенести на завтра - Перенести задачи на завтра
Перенести на день вперед - Перенести задачи на день вперед
Перенести на день назад - Перенести задачи на день назад
Время - подменю для установления атрибута "время начала" задач
Установить время - Установить время начала задач
Перенести на час вперед - Перенести задачи на час вперед
Перенести на час назад - Перенести задачи на час назад
Перенести на сейчас - Перенести задачи на текущее время
Выполнить задачу - Выполнить выбранные задачи
Флаг Помнить - Установить/сбросить флаг напоминания на выбранные задачи
Флаг Выполнить - Установить/сбросить флаг выполнения на выбранные задачи
Отобразить Заглавными - Отобразить заглавными буквами текст выбранных задач
Отобразить Маленькими - Отобразить маленькими буквами текст выбранных задач

Разное

Вставить из Протозадачи - Вставить задачу из протозадачи
Вставить из Буфера - Вставить задачу из буфера обмена
Вставить с заминкой - Вставить задачу с атрибутом "состояние", установленным в "Заминка"
Напоминание - Вставить задачу типа "Напоминание"
Метка Дня - Вставить задачу типа "Метка Дня"
Метка Дня На... - Вставить задачу типа "Метка Дня" на определенный день
Метка Времени - Вставить задачу типа "Метка Времени"
Метка Времени На... - Вставить задачу типа "Метка Времени" на определенное время
Идея - Вставить задачу типа "Идея"
Электронное письмо - Вставить задачу типа "Послать email"
Звонок - Вставить задачу типа "Звонок Исходящий"
Покупка - Вставить задачу типа "Покупка"
Встреча - Вставить задачу типа "Встреча"
Помнить - Вставить задачу типа "Для Запоминания"
Документ - Вставить задачу типа "Документ"
Просмотр - Вставить задачу типа "Просмотр в Интернете"
Проблема - Вставить задачу типа "Проблема"
Bug - Вставить задачу типа "Программная ошибка"
Добавить к Протозадачам - Добавить выбранные задачи к Протозадачам
Сделать периодичными - подменю для добавления выбранных задач к календарю
Сделать Ежедневной - Сделать выбранные задачи событиями типа "Ежедневно"
Сделать Еженедельной - Сделать выбранные задачи событиями типа "Еженедельно"
Сделать Ежемесячной - Сделать выбранные задачи событиями типа "Ежемесячно"
Сделать Ежемегодной - Сделать выбранные задачи событиями типа "Ежемегодно"

Сервис

Язык Интерфейса - подменю выбора языка Интерфейса
Английский - выбрать Английский язык Интерфейса
Русский - выбрать Русский язык Интерфейса
Македонский - выбрать Македонский язык Интерфейса
Очистить список извещений - Очистить список извещений
Создать папку дня - Создать папку дня в формате "dd-mm-yy"
Открыть папку дня - Открыть папку дня
Личное - Открыть для просмотра файл Личной информации
Полезное - Открыть для просмотра файл Полезной информации

Помощь

Прочти меня - Открыть для просмотра файл ReadMe
Домашняя страница - Открыть для просмотра в браузере домашнюю страницу Информайзера
Кредиты - Открыть для просмотра файл благодарностей
О программе - Информация о программе

[ к оглавлению ]

Панель управления

Основные команды доступны с панели управления:

Соединение | Устанавливает соединение
Новая задача | Новая задача
Сохранить задачу | Сохранить задачу
Удалить задачу | Удалить задачу
Свойства задачи | Свойства задачи
"В работе" | Установить состояние задачи "В работе"
"Заминка" | Установить состояние задачи "Заминка"
"Сделано" | Установить состояние задачи "Сделано"
"Несделано" | Установить состояние задачи "Несделано"
Прио Выс | Установить самый высокий приоритет задач
Прио 1 | Установить самый приоритет N1 задач
Прио 2 | Установить самый приоритет N2 задач
Прио 3 | Установить самый приоритет N3 задач
Время | Установить время
Время на 1 час назад | Установить время на 1 час назад
Время на 1 час вперед | Установить время на 1 час вперед
На Дату | Установить дату
На Сегодня | Установить на сегодня
На Завтра | Установить на завтра

[ к оглавлению ]

Горячие клавиши

Большинство часто используемых команд Информайзера могут быть выполнены посредством нажатия горячих клавиш на клавиатуре:

[Ctrl]+N | Создать новую задачу
[Ctrl]+S | Сохранить задачу
[Ctrl]+D | Установить дату начала задачи
[Ctrl]+T | Установить время начала задачи
[Ctrl]+G | Выполнить задачу
[Ctrl]+R | Установить/сбросить флаг напоминания
[Ctrl]+Num[*] | Менять приоритет задачи
[Ctrl]+Num[+] | Менять состояние задачи
[Ctrl]+[Enter] | Показать/скрыть свойства задачи
[Ctrl]+[Del] | удалить все выделенные задачи
F2 | Показать/скрыть Контакты
F3 | Показать/скрыть Ссылки
F4 | Установить состояние задачи "В работе"
F5 | Клонировать задачу из уже существующей
F6 | Перенести задачу на сегодня
F7 | Установить состояние задачи "Заминка"
F8 | Установить состояние задачи "Сделано"
[Ctrl]+F11 | Показать встроенный калькулятор
[Ctrl]+F10 | Вставить задачу из буфера обмена

[ к оглавлению ]

Свойства задачи

Свойства каждой задачи могут быть изменены посредством окна редактирования свойств:

Вызвать окно свойств задач можно кликнув дважды мышкой на задаче в списке задач или по горячей клавише Ctrl-Enter.

Совет: Закрытие окна свойств задачи автоматически сохраняет редактируемую задачу!

Задача имеет следующие свойства:

Задача & Комментарий |
Задача | Тектовое описание задачи длиной до 240 символов
Комментарий | Комментарий к ходу выполнения задачи
Атрибуты |
Тип | Тип задачи
Приоритет | Приоритет задачи
Состояние | Состояние задачи
Исполнитель | Исполнитель задачи (ответственный)
Флаги |
Напомнить | Напомнить о задаче в соответствующее время = времени начала задачи
Выполнить | Выполнить задачу в соответствующее время = времени начала задачи
Даты и времена |
Дата начала | Дата начала задачи
Время начала | Время начала задачи
Дата окончания | Дата окончания задачи
Время окончания | Время окончания задачи
Проект |
Проект | Наименование проекта, к которому принадлежит задача

Совет: Вы можете быстро вставить задачу определенного типа дважды щелкнув на протозадаче в списке протозадач.

[ к оглавлению ]

Типы задач

Основные типы задач, с которыми оперирует Информайзер следующие (в алфавитном порядке):

Архив | архивировать что-либо
Просмотреть | Открыть страничку Интернет
Программная ошибка | Есть "BUG" где-то в программе
Покупка | купить что-нибудь
Звонок Входящий | Есть Входящий Звонок
Звонок Исходящий | Есть Исходящий Звонок
Проверка | Проверить что-либо
Комментарий | Комментарий к чему-либо
Копировать Информацию | Копировать Информацию из одного места в другое
Документ | Работа над каким-либо документом
Загрузка | загрузить что-то из Интернета
Забота о здоровье | позаботиться о чьем-либо здоровье
Идея! | Есть отличная идея!
Информировать | Информировать кого-либо о чем-либо
Инстоллировать | Инстоллировать какую-либо программное обеспечение
Встреча | Намечена встреча с кем-либо
Запомнить | Запомнить что-либо
Открыть | Открыть какой-либо файл (или приложение)
Оплата | Оплатить какие-либо услуги
Печатать | Напечатать документ
Проблема | Есть проблема определенного рода, которую надо решить
Программировать | Программировать что-либо
Получить почту | Получить электронную почту
Релаксация | Немного отдохнуть
Ремонт | Отремонтировать что-либо
Найти | Найти что-либо в Интернете
Отослать почту | Отослать электронную почту
Подписать | Подписать какие-то документы
Переговорить с... | Переговорить с кем-либо о чем-либо
Подумать о... | Подумать о чем-либо
Тренировка | Тренироваться в чем-либо
Извещение | Извещение о каком-либо событии

[ к оглавлению ]

Первый запуск

Следующий фрагмент кода программы (Delphi Pascal) иллюстрирует то, что происходит при первом запуске программы:

// if flag is on - delete
if ( fAutoDeleteDoneTasks ) then begin
DeleteDoneBefore( IncDay(date, -1) );
end;

// try to insert day reminder
mInsertDateMarkClick( nil );

if ( Date <> lastLaunchDate ) then begin

// try to insert TimeMarks
InsertTimeMarks1Click( nil );

// try to analize calendar
if ( fAnalyzeCalendar ) then begin
mAnalyzeCalendarClick( nil );
end;

// go thru all birthdays in contacts
if ( fAnalyzeContacts ) then begin
AnalyzeContacts1Click( nil );
end;
//.................
// Mute & shift
//.................
if fMuteExpiredTasks then begin
MuteYesterdayExpiredTasks();
end; // fMuteExpiredTasks

if ( fShiftMutedTasks = true ) then begin
ShiftYesterdayTasks();
end;//if fShiftMutedTasks=true

end;// if

Поясним, что происходит при первом запуске программы:
Удаляются вчерашние выполненные задачи
Вставляется Метка дня на сегодня
Вставляются Метки времени на сегодня
Анализируется Календарь и вставляются напоминания о событиях.
Анализируются Контакты и вставляются напоминания о датах
У вчерашних невыполненных задач станавливается состояние "Заминка"/"Отложено"
Вчерашние невыполненные задачи с состояниями "Заминка"/"Отложено" переносятся на сегодня

При этом список извещений может выглядеть следующим образом:
---- В работе ---- 09:00 05.09.02
Иванова - Именины (!) вскоре.
Кудашева - День Рождения (!) вскоре.
Принять почту БЭ 2-й раз
Принять почту БЭ
Полить цветы
Call Oxana
Call Oxana
Проверить, если надо, то зарядить мобильный!
Call: Ma
Окончание работы (пон-чтв)

Совет: Внимательно прочитайте список извещений при первом запуске!

[ к оглавлению ]

Фоновая работа программы

Даже когда пользователь программы не совершает никаких действий, каждую секунду программа запускает процедуру проверки наступления времени для различных событий. Иллюстрирует это отрывок из программы, приведенный ниже.

procedure TForm1.RxTimerEvent1Timer(Sender: TObject);
var initialDate, iTime, cTime, curDate: TDateTime;
time, tasktime, t1, t2: string;
WasInEditState: boolean;
begin

WasInEditState := IsEditState( dm.tasksQ );

timeCheck();
taskCheck();
if WasInEditState then begin
dm.tasksQ.Edit;
end;//if

// to remove InformForm from the screen
if ( (informForm.Visible = true) and (informForm.SecretPanel1.Active = false) ) then begin
informForm.Hide;
end;//if
end;

В процедуре taskCheck производится контроль наступления событий и при необходимости выдаются напоминания о наступлении того или иного события.

[ к оглавлению ]

Ввод задач

Существует несколько способов создать новую задачу:

Кликнуть мышкой кнопку "Ins" на панели инструментов
(простейший способ создания новой задачи).
Нажать комбинацию горячих клавиш Ctrl-N на клавиатуре
(быстрейший способ создания новой задачи).
Выбрать в главном меню пункт Задача-Вставить
(используется меню).
Дваджы щелкнуть мышкой в списке задач на отметке времени.
Если щелкнуть на задаче специального типа (так называемая "Метка Времени"), то вводится новая задача с предопределенным временем - таким как время у задачм типа Метка Времени.
Дваджы щелкнуть мышкой в списке Протозадач
(вводится новая задача на основе протозадачи).
Выбрать в меню пункт Клонировать
(создается новая задача на основе существующей - тоже что 2 команды Копировать/Вставить).
Вызвать контекстное меню нажатием на правой клавиши мыши, выбрать пункт меню Вставка Новой Задачи
Выбрать в меню пункт Вставка из Буфера Обмена
(вставляется новая задача Из содержимого текстового Буфера Обмена). Можно использовать клавишу F10.
Совет: Используйте комбинацию горячих клавиш Ctrl-N для быстрой вставки новых задач.

[ к оглавлению ]

Контакты

Примечание: Извините, данный раздел еще не готов и будет написан позже.

[ к оглавлению ]

Блокнот

Примечание: Извините, данный раздел еще не готов и будет написан позже.

Снейкус: Использовать встроенный Блокнот для быстрого ввода текста и печати намного легче, чем использование стандартного notebook MS Windows!

[ к оглавлению ]

Календарь

Примечание: Извините, данный раздел еще не готов и будет написан позже.

[ к оглавлению ]

Ссылки

Примечание: Извините, данный раздел еще не готов и будет написан позже.

[ к оглавлению ]

Работа шаг за шагом

Примечание: Извините, данный раздел еще не готов и будет написан позже.

[ к оглавлению ]

Дополнительная информация

Примечание: Извините, данный раздел еще не готов и будет написан позже.

[ к оглавлению ]

© 2002 Informaizer.com